Techno

things which came out my laptop

Install Subversion 1.5 on Ubuntu Karmic

Ubuntu Karmic includes 1.6.x version of Subversion but our source control server is not upgraded to 1.6. Its still in 1.5 version. Don’t ask me why I am interested in older versions of things, Mainly I work with remote team and SVN server is also hosted remotely hence I’m forced to consider downgrading my version of subversion so that my local working copy wont get corrupted.

First remove 1.6 version of svn from karmic installation,
1
2
3
sachin@sachin-laptop:~/Utility/utilscript$ svn --version
svn, version 1.6.5 (r38866)
sachin@sachin-laptop:~$ sudo apt-get remove subversion
Ubuntu Januty contains Subversion 1.5 in security packages, hence add jaunt package entry to your /etc/apt/sources.list,
1
deb http://security.ubuntu.com/ubuntu jaunty-security main
Check if apt-get can see 1.5 version of subversion,
1
2
3
4
5
6
7
8
9
10
sachin@sachin-laptop:~$ sudo apt-cache showpkg subversion
Package: subversion
Versions:
1.6.5dfsg-1ubuntu1 (/var/lib/apt/lists/in.archive.ubuntu.com_ubuntu_dists_karmic_main_binary-i386_Packages) (/var/lib/dpkg/status)
Description Language:         File: /var/lib/apt/lists/in.archive.ubuntu.com_ubuntu_dists_karmic_main_binary-i386_Packages
MD5: 15da1bb51fb2e9ea5e25b3a489b864d9
1.5.4dfsg1-1ubuntu2.1 (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_jaunty-security_main_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_jaunty-security_main_binary-i386_Packages
MD5: 15da1bb51fb2e9ea5e25b3a489b864d9
Quick look at man pages of apt-get showed me how to specifiy revision using “=”, When I first time tried to install 1.5.4dfsg1-1ubuntu2.1, it failed,
1
2
3
4
5
6
sachin@sachin-laptop:~$ sudo apt-get install subversion=1.5.4dfsg1-1ubuntu2.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: subversion: Depends: libsvn1 (= 1.5.4dfsg1-1ubuntu2.1) but 1.6.5dfsg-1ubuntu1 is to be installed E: Broken packages
So you need to older version of libsvn1 to comply with subversion version,
1
sachin@sachin-laptop:~$ sudo apt-get install libsvn1=1.5.4dfsg1-1ubuntu2.1
and now subversion, sachin@sachin-laptop:~$ sudo apt-get install subversion=1.5.4dfsg1-1ubuntu2.1 here you go, check svn version,
1
2
3
sachin@sachin-laptop:~$ svn --version
version 1.5.4 (r33841)
compiled Aug  7 2009, 01:44:11
Happy coding…